Jump to content
Geochemist's Workbench Support Forum
Sign in to follow this  
Suma

unable to save a new thermo.dat file into the folder

Recommended Posts

Hi,

 

I edited thermo.dat file and tried saving it as a new file but I keep getting the error saying "you don't have permission to save in this location. Contact the administrator to obtain permission" though I have all the admin privileges on my laptop. Attached please find the error snapshot.

 

As a workaround, I created a new txt file with a dat extension in the Gtdata folder. I tried to change the input file for the thermodynamic data but I get the error saying that my new file is not found.

Could you please help me with this issue?

 

Thanks.

Suma K

post-10418-034170100 1350684036_thumb.png

Share this post


Link to post
Share on other sites

Hi Suma,

 

The Program files folder is protected by Windows, so you can't edit or write anything to that folder. If you want to save custom datasets or scripts, you must so in a different folder, such as User - Suma, or the Desktop. It's also generally a good idea to change your working directory from Program files to something like Users - Suma or the Desktop.

 

Hope this helps,

 

Brian Farrell

Aqueous Solutions LLC

Share this post


Link to post
Share on other sites

Hi Brian,

 

Thanks for your reply.

I remember you citing on the forum that you could add enargite in the thermodynamic data and then plot enargite Eh-pH diagram. I have been trying to generate that diagram but I cannot see enargite on the plot even after adding all the relevant data. Could you please assist me with this?

 

Thanks,

Suma

Hi Suma,

 

The Program files folder is protected by Windows, so you can't edit or write anything to that folder. If you want to save custom datasets or scripts, you must so in a different folder, such as User - Suma, or the Desktop. It's also generally a good idea to change your working directory from Program files to something like Users - Suma or the Desktop.

 

Hope this helps,

 

Brian Farrell

Aqueous Solutions LLC

Share this post


Link to post
Share on other sites

Hi Brian,

 

It seems that I already used most of the 500K upload quota and hence can't upload anymore. But here is the thermodata for enargite (using the same data posted by FTA (fernando) on this website) that I incorporated into my thermodata file in accordance with the required format.

Enargite type= enargite

formula= Cu3AsS4

mole vol.= 88.350 cc mole wt.= 393.7996 g

6 species in reaction

3.000 Cu+ 1.000 As(OH)4- 4.000 SO4--

-5.000 H2O -7.500 O2(aq) 6.000 H+

465.4360 414.1113 362.0154 312.9855

263.9463 221.6313 186.0364 156.4474

 

I used the GUI to select the species. I don't know how to pull the script from elsewhere (did not use command tab)

Here is what I did:

I diagrammed Cu+ on Eh-pH (or O2(aq)-pH) axes, added As(OH)4- and SO4-- under the "in the presence of".

I assumed activity for all the species as 0.001.

 

Thanks & regards,

Suma

Share this post


Link to post
Share on other sites

Hi Suma,

 

It sounds like you've followed the necessary steps in Act2, perhaps the error is in the way you added Enargite to the thermo data. Please send your themo dataset to support@gwb.com.

 

To create a script (whether you used the GUI or the command line), just go to File - Save As... to create a .ac2 file. Once this is done you can just double-click the file to open up your saved run.

 

Regards,

Brian

Share this post


Link to post
Share on other sites

Hi Suma,

 

Thanks for sending your dataset and script. Act2 is using thermo.dat, the default thermodynamic dataset. You need to tell Act2 (and the other GWB programs) when you want it to use an alternative dataset. Besides that, your script looks fine.

 

There are several ways to do this. Using the GUI, go to File - Open - Thermo Data... and select your dataset (mythermo.dat).

 

If you have the folder with your thermo data open (or the thermo data saved to your desktop) you can just drag (assuming you have GWB 9) the icon for the thermo dataset into Act2.

 

From the command line, use a command like data = "C:\Users\Suma\mythermo.dat"

 

You'll want to make sure your dataset is a .dat file, and not a .txt file. When you name it, make sure the "All Files" option is selected, rather than Text Documents (*.txt).

 

Hope this helps,

Brian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...