Jump to content
Geochemist's Workbench Support Forum
Sign in to follow this  
jnabiyar

TDS in React

Recommended Posts

I promise this is my last question!

 

So, my when I am creating a 1D simulation in X1t, I am easily able to input my initial TDS values and can see it graphically starting at my desired TDS value. But in React, when give it my initial TDS value, it does not show it graphically starting at that value. For example, I have an initial TDS value of 16.9 g/L. For some reason it will plot a TDS value starting at 75 g/L at year "0".

 

Any ideas?

 

Thank you,

 

Jay

Share this post


Link to post
Share on other sites

Hi Jay,

 

Can you post your example script? Just save it as a .x1t file.

 

Thanks,

 

Brian Farrell

Aqueous Solutions LLC

Share this post


Link to post
Share on other sites

Hi Jay,

 

Oops, I guess the problem is with your React example, which is saved with the .rea extension. Your X1t example will be saved as a .x1t file. In either case, you just set up your model then go to File - Save as to save your run.

 

When you add a reply to this topic, just look for the "Attachments" section and browse for your file, then click "Attach This File." If you post both your React and X1t examples that would be helpful.

 

Thanks,

Brian

Share this post


Link to post
Share on other sites

Hi Jay,

 

Are you sure this is the script that is giving you problems? The TDS isn't saved in your input anywhere (React will calculate TDS as a result), but it's still close to 16 g/l at the beginning of your run (Xi, or reaction progress = 0). Perhaps you need to check your axes in Gtplot and make sure you're actually looking at the starting point?

 

Regards,

Brian

Share this post


Link to post
Share on other sites

Hi Brian,

 

I do apologize. I sent the wrong script. This is the script that is giving me the problems. I'll insert an initial value of 16900 mg/kg and after the run, it will plot an initial value of 71500 mg/kg.

 

Jahed

GarumBatchKineticModelFloThru2.rea

Share this post


Link to post
Share on other sites

Hi Jay,

 

The TDS isn't really a constraint in your model. Rather, GWB will use the value you specify to convert your input constraints into molal units, where necessary. The value you see in the output is actually calculated by adding the masses of all solutes in the final speciated fluid. Assuming you've accounted for everything in the fluid, the TDS measured from the lab should be pretty close to the output.

 

In your case, I think the calculated value is different from the value you specify primarily due to the CO2 in your system. The high CO2 fugacity adds a lot of dissolved CO2 to your system. If you look at the concentrations of species in the printed output, you'll find CO2(aq) is the most abundant species by far.

 

It turns out that fluid degassing between sampling and analysis can lower the TDS content of a fluid. If your fluid was sampled at pressure (f CO2 = 100) it surely lost a lot of CO2 prior to analysis. To see how this works, you can add the CO2 back into your fluid using a "sliding fugacity path". Start with your initial system at atmospheric conditions (I'm guessing you'll have a pH value closer to neutral, otherwise set log f CO2 to -3.5), then move to the reactants pane and click "add" - Sliding - Gas... CO2(g), then specify a target of 100. You'll see how dissolving CO2 into your fluid sends the TDS up.

 

Hope this helps,

 

Brian

Share this post


Link to post
Share on other sites

Brian,

 

Thank you. I'm not sure if you noticed but when you do run the model, and have a simulation period from 0 to 1000 years, it doesn't necessarily simulate to 1000 years according to the results. That is another issue that I am having.

 

J

Share this post


Link to post
Share on other sites

Hi Jay,

 

What version of GWB are you running? Can you tell me when the simulation ends for you? Is there any problem solving the model? Do you autoscale turned off in Gtplot, by any chance?

 

Thanks,

Brian

Share this post


Link to post
Share on other sites

I am running GWB9. I am running the simulation from 0 to 1000 years. I am not sure why it is not simulating to 1000 years. When I run X1t, it plots it on Xtplot. It autoscales itself. I just can't figure it out.

 

Jay

Share this post


Link to post
Share on other sites

Hi Jay,

 

Your X1t script runs to 1000 years as far as I can tell. Look for an Xi = 1 at the bottom of the Results pane. There should also be a dialog box which comes up telling you "Run complete: Simulation ended successfully at year 1000" and giving you the option to plot your results. In Xtplot, look for the Time levels tab to select the time step to plot.

 

There is an issue with your React script however, due to some changes to the time step limitations implemented in GWB 9 (earlier versions do not have this problem). Basically the combination of flow-through path, in which mineral mass is removed at each step, and kinetic precipitation/ dissolution reactions, in which the mass of a mineral factors into the reaction rate (and the limiting time step as a result) causes React to take increasingly small time steps. This will be fixed in the next maintenance release.

 

Regards,

Brian

Share this post


Link to post
Share on other sites

Hi Jay,

 

Just wanted to let you know that we've come out with maintenance release 9.0.6, which fixes a problem in which React takes too small time steps when running flow-through models containing both kinetic reactants and buffer minerals. I think that should take care of the problem you mentioned.

 

Regards,

Brian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...