Jump to content
Geochemist's Workbench Support Forum
Michael P

Edits to Thermo.dat not showing up in RXN

Recommended Posts

Hello,

 

I'm trying to add to the thermo.dat database a basaltic glass so that I might balance its dissolution with CO2 consumption.

 

In the database editor everything seems fine up until I try to 'save.' Save-as works fine, but just using 'save' doesn't proceed- I get some sort of permissions error. Fine- I can save-as once I'm certain of my changes with a new name. It won't even let me save-as then replace an existing name, btw.

 

When in RXN, I chose the new and improved database with my basaltic glass included. (Which I've just checked by opening only the database editor) But the temporary dialogue box clearly shows the mineral count, and it's 1 less than I expect. Lo- when I try to choose the mineral I just added- it isn't there!

 

Have you experienced any permissions issues when saving databases? Or databases not opening properly within RXN? I've tried shutting down the software and even restarting the computer. Still not recognizing my database amendment from inside RXN.

 

Thank you!

M

Share this post


Link to post
Share on other sites

Hi M,

 

You might experience a problem saving a dataset if you don't have write permission in the specified directory or if you're trying to change a dataset that is currently being used by another GWB program (for example, if Rxn is open and loaded with the dataset you're trying to change). If the latter case is true, just close the other GWB program(s) and you should be able to save your thermo dataset.

 

As for the new mineral not showing up, you should verify that the new dataset was actually loaded into Rxn. Here's another forum post that should help clear this up.

 

Hope this helps,

 

Brian Farrell

Aqueous Solutions

Share this post


Link to post
Share on other sites

BTW, it's typically a good idea to save your custom thermo datasets to a different name so that you don't confuse yourself or others who might be working with your scripts or datasets.

Share this post


Link to post
Share on other sites

Hi Brian,

 

Thanks for your reply.

 

However, after reading it and the suggested post about loading the proper dataset, it still is not showing up.

 

Here is what I just did:

1) Closed all instances/programs of GWB.

2) Opened the thermo database editor and confirmed a- my added basaltic glass was there (yes), and b- that the mineral count says 635 not 634 of the previous iteration (yes)

3) Closed the thermo editor

4) Opened RXN

5) File >>open>>thermo data... --> chose the one I just confirmed to be correct in step#2, but when I do, the temporary dialogue box says 634 minerals :( and so, my basalt is not on the list of minerals :(

 

So I don't think it's a operating system preferences thing, since it's clear by going to the saved dataset that the database amendment 'sticks'. And yes, thank you, I do save under an obviously edited name to know which one I'm using, and to not mess up the default dataset.

 

Any additional thoughts on loading my dataset into RXN and having it use the one that is clearly showing as correct on the thermo-editor side?

 

Thank you,

 

Michael

Share this post


Link to post
Share on other sites

Hi Michael,

 

What release are you using? You can find this information in Rxn or any other GWB program by going to Help -> About Rxn. Can you load the edited database into any of the other programs successfully? Would you mind attaching it, so that I can try?

 

Thanks,

Brian

Share this post


Link to post
Share on other sites

Brian,

 

Thanks for the quick reply!

 

Release 10.0.2 (Build 6257) 32-bit

 

:) This forum says 'You aren't permitted to upload this kind of file'. It's a .tdat file...

 

Please advise.

 

Thanks,

 

Michael

 

 

Share this post


Link to post
Share on other sites

Also, You asked if I could load it into other programs. The answer is no- not within GSS, where I've worked extensively with SpecE8 in the past.

Thank you.

Share this post


Link to post
Share on other sites

Okay, the forum should now be able to accept .tdat and .sdat attachments. Could you please try again? You may need to refresh your browser.

Share this post


Link to post
Share on other sites

A log K of 500 at any principal temperature indicates to the programs that no data is available at that particular temperature. The programs will not load species whose log K values don't span the temperature range of the calculation. In some cases, the extrapolate option can be used to calculate a log K if data is available at one or more principal temperatures. Since your mineral has a log K of 500 at every principal temperature, though, it's as if the species doesn't exist. I've attached a modified thermo dataset that Rxn will read ( I simply changed the log K value at 25 C to 499). This log K isn't meaningful at all, but it will allow you to balance reactions at the very least. If you have an equilibrium constant for the reaction you've added to the dataset, for any of the principal temperatures, you should use those values.

 

Best,

Brian

thermo for glass dissAlterLogK.tdat

Share this post


Link to post
Share on other sites

Thank you Brian. Log K's are unavailable, but definitely good to know adding one will help with balancing.

 

Best,

 

Michael

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...