Jump to content
Geochemist's Workbench Support Forum
elg0086

Raffinate Solution X2t Model

Recommended Posts

Hello,

I am attempting to model an in-situ leaching process with X2t. Sulfate concentrations in the raffinate solution are quite high and the model is having trouble converging, producing the error:

Solving for initial state of each nodal block.
Residuals too large, 689-th interation

Any suggestions as to why specifically the model is having trouble? Thank you!

-Erik

 

Raffinate_9_28_18.x2t

Share this post


Link to post
Share on other sites

Hello Elg0086,

Thanks for attaching your X2 script. I took a look at it and noticed a few issues:

1. You have constrained your initial system with  several minerals that are quite unstable at the pH/T/oxidation state defined for your system. For example, Anorthite is not very stable at the pH-T of your initial system.

2. There are not many environments in which magnetite is in equilibrium with a very oxidizing solution/atmosphere. Thus, magnetite puts a lot of ferrous iron into the system. Even after removing magnetite from your system, you still have a solution which is way too concentrated with Cl-, SO4--, Na+, and Ca++.

I would recommend that you start with React and check the initial state (Run-->Go initial) of your X2T initial system as well as your inlet fluids before moving to X2T. 

Hope this helps.

 

Bests,

Melika Sharifi,

Aqueous Solutions, LLC

 

Share this post


Link to post
Share on other sites

Melika,

Thank you for the response. You are correct in that several of these minerals would not be stable in the system but we are anticipating rapid dissolution. I have since edited the mineral composition (removed anorthite and magnetite for simplicity) and adjusted the partial pressure of oxygen in the model (which  was not set correctly).

The Inlet fluid (groundwater) was sampled on site and analyzed by a commercial lab. The raffinate chemistry was provided by the manufacturer. Both solutions have been balanced using specE8. The model appears to be having trouble with the initial basis. Should mineral volumes be part of the reactants pane instead of the initial basis? Thank you.

-Erik

 

Share this post


Link to post
Share on other sites

Hi Erik,

Thanks for providing the additional information. If you see rapid dissolution of minerals in your system, they should not be set as being in equilibrium with your initial system. You can, instead, put them on the Reactants pane as kinetic minerals. Another thing that you might find helpful is to set Cl- as the balance species.

Bests,

Melika Sharifi,

Aqueous Solutions, LLC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×