Jump to content
Geochemist's Workbench Support Forum
Koitoliver

Something wrong with my GSS

Recommended Posts

Hello everyone!

There is something wrong with my GSS software. The problem start after I transferred my student client to a new pc. When I opened spreadsheets that i had made in my old pc, at first there was no HCO3- ionic species present in the add analyte selection of the new software. I do not remember If I made a new one or not. Starting from that moment i started getting anomalous behavior from the soft when calculating HCO3- from entered carb hardness values, faulty CBE calculations etc.

In the attached image one can see that the software identifies some of the carb hardness values (upper half) and attributes them to calculate HCO3- concentrations and CBEs. But for the lower half of the data, the soft seems not to be able to identify the entered values for some reason. Also all the calculated CBEs seem not to match with the ones calculated manually. And for the lower half of the data, the CBEs indicate missing carbonate data.

ex1.jpg

Share this post


Link to post
Share on other sites

Also I just noticed that when I create a new spreadsheet I am missing add pH option in the Add Analyte menu.

Share this post


Link to post
Share on other sites

Dear Koitoliver,

In the screenshot you provided, the analyte HCO3- is already added to the spreadsheet and therefore you cannot add it again when you select “+ analyte”.

The hardness of the fluid sample is a result of calculation; it  cannot be used as a constraint. Only the HCO3- concentration (typically the HCO3- component, but you can alternatively constrain the free HCO3- ion) or the carbonate alkalinity can be used as constraints. I quickly did a charge balance calculation with a few of your samples and I am seeing slightly different results from your calculations. The charge imbalance error from my quick calculation did not match the value in your row 1 sample calculation. However, my calculations for the row 19 and row 20 samples did match with your charge imbalance error result. This leads me to believe something is missing (such as a HCO3- constraint) and you haven’t recalculated your analytes for the first group of samples after changing the spreadsheet. To recalculate right click on the charge imbalance column header and select ‘Recalculate Analyte’.

Again, is it possible you had HCO3- values entered previously on your old spreadsheet? Maybe the values were accidentally deleted? Did you switch from a different thermo dataset from when you reopened the spreadsheet? The thermo_phreeqc.tdat dataset uses carbonate (CO3--) as a basis species instead of bicarbonate (HCO3-). If you did not allow the substitution of CO3-- for HCO3- when you switched thermo datasets then it will delete the HCO3- component’s column. That could also explain why you can’t find HCO3- in the list of basis entries.

With regards to pH, the new GSS spreadsheet defaults to include pH as one of the analytes when a new spreadsheet is created. If it’s already in your spreadsheet, you won’t be able to add it again. Perhaps you hid the analyte? Under the Data menu, you have the option to hide and show analytes or samples.

Please try check your spreadsheet according to the suggestions above. If you need further assistance, please attach your script.

Best,

Jia Wang

Aqueous Solutions LLC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×