Jump to content


Photo

React error

react; gss launch

  • Please log in to reply
1 reply to this topic

#1 Dino

Dino

    Member

  • Members
  • PipPip
  • 18 posts
  • Gender:Male

Posted 21 September 2017 - 09:58 AM

I see that this question was asked back in 2012, but I did not find a response with an answer.  So...

 

I tried launching React from GSS.  After running the simulation and trying to look at the results with 'view results', I get the following error "Usage react [-i input_script] [-d thermos_dat] [-s surface_data] [-cd] [-nocd]"  Displaying graphs is not a problem.  This is a simulation in which the temperature of a solution is increased from 25 to 90, equilibrated with CO2, and the resulting solution decrease to 25.  I get the error at any stage when trying to 'view results'.  Figuring that there was some disconnect between GSS and React, I saved the file after running several simulations to get the answer I needed.  I then opened the saved file with WordPad and copied and pasted the steps into the Command tab.  Everything loaded and the simulations worked as before, however, requesting a 'view results' gave the same error.  Where is the error and how to fix it?

 

Thanks,

 

Dino
 


  • 0

#2 Brian Farrell

Brian Farrell

    Advanced Member

  • Admin
  • PipPipPip
  • 772 posts
  • Gender:Male

Posted 21 September 2017 - 01:03 PM

Hi Dino,

 

After completing a calculation, React produces in its current working directory a text output file (React_output.txt) and a plot output file (React_plot.gtp). Going to the working directory and double-clicking on the former is equivalent to hitting "View Results" and double-clicking on the latter is equivalent to hitting "Plot Results". What happens if you go to the working directory (you should see the directory listed at the very top of React's window) and double-click the text file that's just been generated? Can you change the working directory (go to File - Working Directory and browse to some other folder, like the Desktop), rerun the example, and try to open the text results either by clicking "View Results" or double-clicking on the text file?

 

If you're still having trouble, can you check the file association for .txt files? In Windows 10, find a text output file, right-click on it and select Properties, then look at the program specified after "Opens with". Typically this is Notepad by default. that app works well for the text output, but others, such as Notepad++, will work as well. 

 

Hope this helps,

 

Brian Farrell

Aqueous Solutions LLC


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users