Jump to content
Geochemist's Workbench Support Forum

Dino

Members
  • Content Count

    25
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Dino

  • Rank
    Member

Profile Information

  • Gender
    Male

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks, Jia. I am sorry for bothering you. I appears to be a bonehead mistake on my part...after you called it out. I went back a looked at my Excel graph and...I had not coverted from 'mol' to 'mmol'. Again sorry to have bothered you ...and wasted a bunch of my own time chasing something that I should have checked at the start.
  2. Jia, I still seem to be hung up. I've attached the files you need to run this simulation. I seem to have solve some of the problems, but the simulation does not seem to progress beyond xi = 0. Denis WAK IX.bas WAK IX.1.rea P0798 One k Rate b.bas WAK IX.2.rea thermo.com.v8.r6+(dms-8).tdat
  3. Hmmm. I've still got something wrong. I get a report of the time, but it does not vary. Eventually something becomes unstable and the calculated rate goes from a large positive number to an equally large, but negative number. This probably something quite simple, but I'm stumped. I've attached the .bas file. What i'm trying to do is to react a glass that normally contains Li and Na. I've changed the composition of the glass so that it has no alkali and another 'glass' that is just the alkali. The glass without alkali behaves correctly, but the one without alkali does not. If i change
  4. Jia, Thanks for the clues. I'll try again. I believe I've tried "t", "time", and "Time," but i'll try again. I've included print statements like "Print "Step 1", Time" and such. Every time the parameter Time is shown as 0. As I say, I'll try again. Denis
  5. I am trying to dissolve two phases in water. In one I use a first order dissolution rate law. For the other, I want to use a rate law that is independent of the solution concentrations and depends only on the time since the start of dissolution process, e.g. something like diffusion with a square root of time dependence. I have not found a way of accessing the 'time' parameter that is used outside of the script environment. For example, I'd like to use something like '...t = time...rate = rate_con*t^0.5...' All attempts to date have failed and a search of the users group failed to turn up
  6. It seems the problem resolved by an unknown path. I'd still like to find out what the probable cause was, but... The problem was resolved after shutting down, updating the MS windows (automatic), and restarting, all the following day. Strange!
  7. I am getting an incorrect format error when I try to plot a react output. I've gone back and retrieved an old react input that i know worked and get the same error. The printed output looks normal. When I open the .gtp file with notebook, the only 'text' is "-x-".
  8. I tried to rerun the simulation after deleting the .gtp file...no soap. However, I just tried your suggestion of running an earlier simulation. That worked without error, but there were just as many minerals in the earlier one as in the troublesome one. I then set the graph for pH and reran the troublesome simulation and was able to get the graph without error. Thanks. Denis
  9. I have a simulation of glass dissolving in water with xaffin set to SiO2(am). The SiO2 is kinetic - has a rate equation associated with it. The simulation runs fine until Q/K approaches 1. It then slows dramatically and the slow down appears to be related to changes in Q/K. After letting the simulation run over night, I aborted it and looked at the values of Q/K. These were changing by less than 1 part in 10^7 (see the table below where the first col is the days of reaction, the second is the dissolution rate of the glass and the third is the Q/K. d - 4174.975215 R - 1.33E-17 Q/K - 0.99
  10. I just ran a long simulation. When I tried to graph the results, I got an error that there were too many minerals to plot. I tried many ways to get around this error, including deleting the two gtplot default files, to no avail. When both gtplot files are absent, I get the message that they do not exist and do I care to choose another file. Answering 'yes' gets me a graph of some previous simulation, but clicking the 'plot results' button gives the same result. I'm caught in a do loop. Additionally, clicking the 'view results' button gives me nothing...no file comes up. I've tried 'cntl
  11. here they are. I use a modified (phases added and TRIS) version of the LLNL data base. it is too big to attach. you'll have to change the P0798 rate file since the link would not allow me to upload that type of file (even with the 'txt' extension). BTW, how do you generate a '.bas' file? I've done it in the past, but probably by accident... Denis P0798wSiO2add.9.rea amorphsilica.txt copy P0798 Rate.txt
  12. I have a file with a custom rate law for the dissolution of glass. in separate files, i have custom rate laws for the precipitation of alteration products. I recently added a rate law for the precipitation of amorphous silica and i get a react errro "bad rate law type". However, this rate law is nearly exactly the same as the others that work fine. The only difference is that the glass rate is connected to the amorphous silica through xaffin. Is that the problem? How would i get around that problem? Perhaps use chalcedony as the precipitating phase but with the same thermo properties as
  13. I see that this question was asked back in 2012, but I did not find a response with an answer. So... I tried launching React from GSS. After running the simulation and trying to look at the results with 'view results', I get the following error "Usage react [-i input_script] [-d thermos_dat] [-s surface_data] [-cd] [-nocd]" Displaying graphs is not a problem. This is a simulation in which the temperature of a solution is increased from 25 to 90, equilibrated with CO2, and the resulting solution decrease to 25. I get the error at any stage when trying to 'view results'. Figuring that
×
×
  • Create New...