Jump to content
Geochemist's Workbench Support Forum

Convergence error: Newton-Raphason 999 iterations, max residual is O2


Recommended Posts

Having max residual issues with O2 (aq) and need some advice troublshooting this issue to get the model to converge.  I am trying to run a surface complexation 1D model in X1t trying to model HVO4-- sorption onto ferrihydrite, and I cannot get the model to converge.  I am having to suppress almost all minerals because I have an oversaturation issue if I do not.  My current issue is that oxygen is my largest reidual but I am also getting chloride as well.  I have attached the input and output files for you review.  

Hoping you can have a look, see what I am suppressing, and give me tips to get past this issue.  

Thanks,

Input_V transport model.x1t Output_convergance error.x1t

Link to post
Share on other sites

Hello Nick,

After taking a quick look at your script, I think there are several issues.
 
Suppress is typically used to remove minerals/aqueous species from consideration during simulation. In this case, you are suppressing all the secondary aqueous species in your simulation, which is making it difficult for the program to find the equilibrium state. I would suggest that you start by unsuppressing all the aqueous species and just suppress hematite and ferrihydrite (aged), since your surface dataset contains surbing sites for Ferrihydrite but not Ferrihydrite(aged). You can view your results at the end of the simulation to see what unexpected minerals are forming and then rerun by suppressing those too. You can end up suppressing all the minerals except for the few that you expect to see but starting off by suppressing a few allows you to get a better sense of this process. If you do not want any new mineral to form during your simulation, you can just disable precipitation altogether in the Options dialog.
 
I also noticed that you are setting up your kinetic surface complexation reactions as kinetic redox reactions under the Reactants pane. If you are trying to model kinetic surface complexation reactions, then I think you should use the Kinetic --> Sorbing surfaces option instead of Kinetic --> Redox.
 
Just a tip for general troubleshooting is to always start simple and then add complexities for complicated models like this. The first step is to check whether the initial chemical constraints for your system is allowing the software to solve the equilibrium state of your system before any reaction or transport takes place.  You can do this by just going to Run --> Go initial in your X1t window. If you do that, you'll realize that your initial constraint is not converging. Typically, I would recommend working in React to get the chemical reactions set up and then move to X1t or X2t to build in the transport component.
 
Hope this helps,
Jia Wang
Link to post
Share on other sites

Thank you Jia, this is incredibly helpful.  I have been working through several issues using this simpler approach.  I switched over to React some of the issues I am having.  I reacted my initial solution with reactants from the source and I am having an issue I do am trying to diagnose.  I am having charge balancing issues so I am using chloride for the make-up ion.  When I run the reaction using 5 percent Ferrihydrite (swapped in for Fe+++ in the basis pane), the reaction seems to run just fine (see attached output file).  When I run the reaction with greater than 5 percent ferrihydrite (see .rea file), I am getting a convergence error, with chloride being the residual.  Not sure why adding more Ferrihydrite give me a convergence error, but I am thinking this is a real problem for me in the X1t model I am running.  The aquifer has 10-15 percent ferrihydrite so I am trying to simulate this and cannot seem to.  Do you have any suggestions?  Overall, charge balance and residuals have been a real issue for me and so I am hoping you can help me troubleshoot?

React_output_sx w initial_0.05ferri.txt 10 percent ferrihydrite failure.rea

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...