Jump to content

Convert value by elemental equivalent in GSS bug?


CShort
 Share

Recommended Posts

I've created a GSS using the thermo.com.V8.Rc+.tdat thermo database but want to convert it to the thermo_minteq.tdat. No problem, open -> thermo -> and select thermo_minteq.tdata. Then GWB asks me, through a series of pop up windows, to sort out discrepancies in basis entries.

So I start the conversion and, for example for Arsenic, it says AsH3(aq) is unavailable in the new database and suggests I substitute AsO4----. Sure, that's fine, but my AsH3(aq) data are in units of mg/L (as As) in GSS. I want to preserve the same concentration so I can have my new AsO4---- data in units of mg/L (as As).

What's strange is that it has a checkbox asking if I want to convert value by elemental equivalent. if I check the box I get what I want - the value stays the same. If i do not check the box, the value is converted to accomodate the difference in unit mass.

It seems to me that this should be the opposite - unchecking the box should not do a unit conversion, and checking it SHOULD do a unit conversion.

Is this a bug, or do I just have this backwards?

 

GWB_arsenic_elemental_equivalent1.PNG.8df4b4257e45d5453ceacb0c1787237c.PNG

Link to comment
Share on other sites

Hello,

In your example, you have 0.001 mg/l AsH3 as As. This is equivalent to 0.00104 mg/l AsH3 as itself - this is the value the program carries internally. When you load another dataset, you can convert to another arsenic species using the known elemental mass (as As), Since you chose, AsO4---, you'll see the converted value is 0.001 mg/l AsO4--- as As. The units (mg/l as As) happen to be the same, but the fact that the actual amount of As is preserved is what we really care about by selecting the "convert by elemental equivalent" option. If your original units were as the species itself (AsH3), the conversion that takes place would be more apparent, but either way they are correct.  

If you uncheck the "convert by elemental equivalent" option, the program will simply copy the value it carries internally (0.00104 mg/l to the new spreadsheet entry, AsO4--- in this case. The units may be listed "as As", but if you convert them to "as AsO4---", you'll see 0.00104, which reflects a simple copy from the original internal value, not a conversion.

For a simpler example, let's look at nitrogen species. In thermo.com/v8.R6+.tdat, NH3(aq) is a basis species. 10 mg/l NH3(aq) is equivalent to 8.224 mg/l NH3 as N. Whether the unit is as the species itself or as the elemental equivalent, if you load thermo_minteq.tdat, substitute NH4+, and convert the concentration, you'll end up with 10.59 mg/l NH4+, or 8.224 mg/l NH4+ as N. These are all equivalent to the original data. If you unchecked the "convert by elemental equivalent" option, you'd end up with 7.765 mg/l NH4+ as N, or 10 mg/l NH4+. Neither of these are equivalent to the original input, because the value of 10 stored internally was simply copied, not converted.

BTW, AsH3 has As present in the -3 oxidation state. AsO4---, by contrast, has As present in the +5 state. When using the substitute option, you generally want to pick the equivalent species. I've compared the different oxidation states of As basis and redox species, which are available in GSS, in three thermo datasets below.

thermo.tdat
Basis: As(OH)4- (+3)
Redox: AsH3(aq) (-3)
Redox: AsO4--- (+5)

thermo.com.v8.R6+:
Basis: H2AsO4- (+5)
Redox: AsH3(aq) (-3)
Redox: H2AsO3- (+3)

thermo_minteq:
Basis: AsO4--- (+5)
Redox: H3AsO3 (+3)

Unfortunately, there is no -3 equivalent in thermo_minteq.tdat. Perhaps your original data should be in terms of As(+3) or As(+5), which are likely more common that As (-3)? When presented with multiple oxidation states in GSS, a good strategy is to pick the redox species if you know that your analysis is specifically for that oxidation state, but otherwise use the basis species. 

Hope this helps,

Brian Farrell
Aqueous Solutions LLC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...