Jump to content
Geochemist's Workbench Support Forum

thermo_minteq (Act2)


Kawal
 Share

Recommended Posts

How to use thermo_minteq database in Act to make proper Eh-pH diagram?

 

I tried using it. It gave me msg saying "Reaction for H2(g) is missing, cannot plot water limit"

 

After i said ok it gave me plot but without water limits.

 

also i added H2(g) in minteq database, still its showing me same msg.

 

Can you please help me with this

 

Thanks

 

Kawal

Link to comment
Share on other sites

Hi Kawal,

 

It looks like you also had the issue discussed here. Calling the species whatever you want (O2 (g) and H2 (g)) will work for most calculations, but I think Act2 and Tact look for O2(g) and H2(g) (with no spaces) when they attempt to draw the water stability limits.

 

You need to be very careful when editing thermo datasets. The default thermo.dat is defined from 0-300 C, while the Minteq database only goes to 100 C, so the values you copied into the Minteq database don't match up. The topic referenced above contains instructions for estimating the log K values at the proper principal temperatures.

 

You also need to update the counts of basis, redox, aqueous, minerals, and gases in the dataset as you add species. I think you may have done this for H2(g) but not for H2(aq). The Thermo datasets Appendix to the GWB Reference Manual will come in handy when analyzing and modifying thermo datasets.

 

Regards,

Brian

Link to comment
Share on other sites

Thanks Brian. This was helpful.So in new model there is no checkbox for "water limits" as its written in minteq database:

 

"Visual Minteq does not include H2(g), thus the config->options->"water limits" checkbox for GWB programs Act2 and Tact needs to be unchecked when using this dataset"

 

I have another question related to GtPlot.

 

In Eh-ph diagram plots some of the species overwrite each other. I have attached one of such plots. Is there a way to separate them?

 

Thanks again.

 

Regards,

 

Kawal

Eh-Ph diagram.pdf

Link to comment
Share on other sites

Hi Kawal,

 

I'm not sure about this but I think earlier versions of the code would not work with the Minteq database unless you unchecked the "water limits" option. Now you just get a warning message that you can't include the water limits when using the unmodified Minteq database. You can still toggle water limits on/ off (and modify many other aspects of your plot) by right-clicking your plot and choosing View... or going to Plot - View...

 

In Gtplot and Xtplot there is a little more flexibility in moving around the locations of line labels, but in Act2 and Tact they are placed in the center of the fields which they represent. You can try shrinking the font a little to help distinguish one field from another, and expanding the plot range to pH 16 will also clear things up. You can also just paste your plot into PowerPoint or Illustrator and edit it there.

 

Hope this helps,

Brian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...