Jump to content
Geochemist's Workbench Support Forum

node-by-node setting


maki
 Share

Recommended Posts

Hello,

 

I’m trying to set heterogeneous values in Initial pane and Reactants pane of X2t.

Although constant values are set with no problem, values set by node-by-node have not been correctly reflected in the result of time ‘0’.

 

I show the examples of the heterogeneous setting in 3×3 domain to you.

 

Case1

Correctly reflected case is as below.

2 1 2

2 1 2

2 1 2

 

Case2

The case incorrectly reflected is as below.

2 2 2

2 1 2

2 2 2

In this case, the result of time ‘0’ is as below.

The value in the middle is 2, not 1 in input.

2 2 2

2 2 2

2 2 2

 

When the heterogeneity becomes more complicated, many unreflected cases appear.

I wonder if this phenomenon happens on me only.

In any case, could anyone tell me how to resolve this problem?

 

Attached X2t file includes the node-by-node settings in CH3COO- of Initial pane and in initial biomass of Reactants pane.

 

Thank you for your consideration.

 

Best regards,

 

maki

Link to comment
Share on other sites

Hi maki,

 

It looks like there is currently a problem reading the node-by-node editor. As an alternative, you could use a table file (.txt file) or an in-line table to set values for your heterogeneous fields. The Heterogeneity Appendix to the Reactive Transport Modeling Guide covers these two topics. Please note that the tables must be inverted with respect to the domain because of the way the nodes are indexed.

 

Regards,

 

Brian Farrell

Aqueous Solutions LLC

 

P.S. I've moved your post from the archive of old posts to the front page of the GWB forum.

Link to comment
Share on other sites

Hi Brian,

 

Thank you for your advice.

 

I became able to set the heterogeneous field by using a table file according to your advice and Appendix: Heterogeneity of Reactive Transport Modeling Guide.

 

On the other hand, in-line table setting on Command pane didn’t work. The values of bottom line seem to constrain upper values to be same, just like node-by-node setting.

For example, {1 1 1 2 0 2 2 0 2} in the command changed into {1 1 1 1 1 1 1 1 1} in the initial.

 

For the time being, I will use a table file to set the heterogeneous field.

It would be great if you could also resolve this matter soon.

 

Best regards,

 

maki

Link to comment
Share on other sites

Hi Brian,

 

Thank you for your pointing out.

The matter concerning in-line table setting was cleared up by adding the vertical separators to corresponding lines.

 

I appreciate for your understanding and cooperation.

 

Best regards,

 

maki

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...