Jump to content

Act2 program for UO2++ activity


Recommended Posts

Hello,

 

I am currently trying to conduct some simulations to see the uranium (UO2++) speciations as a function of some conditions such as HCO3- and Ca++ concentrations

 

I am using the REACT module to simulate and graph the UO2++ speciation as function of the pH and HCO3-. Now, I want to use the Act2 model to graph UO2++ activity vs HCO3- activity. I am following the steps: From Act2 > go to File >Open>Reaction Trace; here I am going to my created ".gtp." file. However, I immediately found a error message that said "Exit Act stop: trace: lost x-axis species. Act 2 is ending.

 

Please find attached my command file.

 

Thank you and I will appreciate your help.

 

Claudia

Command.docx

Link to comment
Share on other sites

Hello Claudia,

 

The error message you’re encountering is due to the fact that you haven’t set up your plot axes in Act2. Before you can open the reaction trace “.gtp” file in Act2, you’ll need to set up your activity diagram x and y axes and make sure your reaction path model contains information that matches the axes of your diagram. For example, if you wanted to overlay a reaction trace on an Eh-pH diagram, your reaction path model must contain information on the oxidation state and pH.
Be sure to use the same thermo dataset in both Act2 and React and make sure the relevant species match. For example, if you swap HCO3- for CO3-- in React you should do the same in Act2. For more information, see Sections 5.5 Reaction traces or 6.5 Reaction traces and scatter plots in the GWB Essentials Guide.
Kind regards,
Katelyn
Link to comment
Share on other sites

Hi Katelyin,

 

Thank you for your prompt answer, I was able to open my reaction trace and graph the UO2++ speciation as a function of several conditions. However, I found two things that called my attention:

 

1. Before getting my graph, it displays a message that said the "H2(g) reaction is missing", and I am not sure where should I write this reaction?

 

2. I am suppressing some species that I am not interested to show, and I find difficult to identify the species from the list. I am using "select with", but it is still hard to find them. There is a way that can be more practical to identify these species?

 

Thank you again for your support, :)

 

Claudia

 

Link to comment
Share on other sites

Hello Claudia,

 

I believe the error message you are encountering is related to the default setting to display water limits. The water limits refer to the conditions under which water becomes so oxidizing that it is unstable and breaks down to O2(g), or where it is so reducing that it forms H2(g). Normally you’ll see two dashed lines for the upper and lower water stability limits on an Eh-pH diagram. Act2 by default will only plot species within the water limits, but not outside them. You encounter the error because thermo_minteq.tdat does not include a reaction for the H2(g) species, so it can’t draw the line. You can tell the program to ignore the water stability limits (and prevent the error you’re seeing) by right-clicking on the plot, clicking View…, then unchecking water limits. For more information, see section 3.64 water limits in the GWB Reference Manual.

 

When you open the Suppress dialogue you can change the “list” pulldown to include all species, or only the aqueous species, minerals or gases. If you know a specific species’ name, you can begin typing it to find it more easily. Sometimes it’s helpful to suppress all species, then to unsuppress those that you’d like to include in your diagram. You can also use the “select with...” pulldown to highlight all the species containing a certain basis entry. The “invert selection” button may come in handy. With it, you can unselect what was highlighted before and automatically select species that were not previously highlighted. You can also hold down the Ctrl key and left click to select multiple species or highlight a selection by holding down the Shift key to select adjacent species.

 

Kind regards,

 

Katelyn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...