Jump to content
Geochemist's Workbench Support Forum

saturation indices in output and plot do not match


Recommended Posts

I ran a simple reaction path model reacting quartz, k-feldspar, and muscovite with dilute solution. When I add the minerals in the reactant tab as volumes (cm3) the saturation indices in the output file in early steps do not match what it plotted. However, when I convert the volumes to mass (g) by hand and add the minerals in the reactant tab as mass the saturation indices in the output file match the plot. The plot is the same for both volume and mass added cases but the output files are not. I am attaching the two react files. In both cases K-feldspar reaches saturation at x=0.1 according to the plot, in the case where mineral are added by mass the output matches the plot, but in the case where the minerals are added as volume the output file shows k-feldspar, quartz, and muscovite saturated in the first step.



Link to comment
Share on other sites

Hi Brian,


I am running 10.0.8. I am getting inconsistent results trying to figure this out! I am wondering if the output isn't clearing when I run a new model or something. I re-built both models and am now getting the same behavior for both where the output doesn't match the plot.



Link to comment
Share on other sites

And now I have both in agreement. I'm not sure what is happening but if you can re-create my original problem and provide insight that would be great. A student in my class pointed it out to me this morning so I was working on it with her before trying it on my own as well. I have been using the reactant times option (both above and below 1) to scale the amount of minerals added.

Link to comment
Share on other sites

Hi Alexis,


I haven't found any problem yet, but I'll keep looking. One thing to keep in mind is that an open window of Gtplot will update when you rerun a calculation, but the text file in an editor like Notepad won't refresh itself. You need to click "View Results" once again to open the updated text file. What I've said about Gtplot updating is true assuming React and Gtplot have the same working directory and that you're not changing React's suffix between runs.


You can find the working directory at the top of either app, between the icon and the min, max, and X buttons. Gtplot will additionally list the name of the plot file at the end of the working directory. The default name is "React_plot.gtp". It can be helpful to set a suffix in React to differentiate results files from different calculations. This also prevents React from overwriting your previous results, which enables you to compare different calculations side-by-side. Go to Config -> Output and set a suffix like "_mass" or "_volume" (you don't actually type the " ") then hit "Apply" to set a suffix for your run. After you do so, React will append the suffix to the end of the name of any new text and plot files it generates (React_output_mass.txt, React_plot_mass.gtp).


If you set a different suffix for each React run I think you'll have an easier time comparing results. If you're still not sure about a plot, try refreshing the plot data with the keyboard shortcut "ctrl+U". You might also try "ctrl+R" to reset the plot configuration, then set your axes from scratch. Please try this out and let me know if you're still having problems.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...