Jump to content
Geochemist's Workbench Support Forum

XTPLOT crashing after apparent successful X1T run


O2 transport
 Share

Recommended Posts

Hello Rob,

Taking a quick look at your scripts, I think the main issue here is the dxplot parameter. Setting dxplot to 1e-4 means that over the course of the simulation, the software is going to write out results for reaction progress at an interval of 1e-4, which results in 10,000 timestep entries over the course of a 10 day simulation (a timestep every ~1.4 minutes). The resulting .xtp file is extremely large, causing Xtplot to crash when you try to open the plot file. Perhaps you would want to set the dxplot to something smaller to see if it is sufficient for your needs before increasing the resolution. A good starting point might be something like dxplot = 0.005, which calls the software to print out 200 timesteps over ten days. You can adjust dxplot by going to the Config tab in X1t --> Output... --> change 1e-4 to 0.005. For more information on dxplot, please see section 8.32 in the GWB Command Reference guide. 

Hope this helps,
Jia Wang

Link to comment
Share on other sites

Thanks Jia.  I think this is a case where the student merely plugged something into a previous X1T run.  I thought it might be the dxplot parameter, but I wasn't sure what it should be set too.  Is there ever a reason to have a dxplot of 1e-4?  Is there a dxplot value that would be too high?

Thanks.

Rob

 

Link to comment
Share on other sites

Hi Rob,

You’re welcome Rob. There are some cases where really small dxplot values are called for. For example, if you expect your reaction to progress quickly initially but slows down with time, then you might want to have a small dxplot to capture that initial reaction but it might not be really necessary later on. In that case, you would want to also change your output setting from linear to log scale so that reaction intervals are recorded in logarithmically. In log scale, the gaps between interval increases and thus you will have more detailed record of your reaction at the beginning of your simulation and at a coarser resolution later on. This will also dramatically reduce number of entries you have, making the plotting of the results less intensive on your computer. You wouldn't want to set your dxplot value so high that you end up with timesteps that misses the reaction front moving across your domain. I believe the default value in X1t is 0.02. 

If you find yourself often outputting large plot files and Xtplot noticeable struggling, you might want to check the installation version of the software you have, 32-bit or 64-bit. With a 32-bit installation, your computer is limited to accessing 4GB of RAM. If you are able to run the 64-bit version, that would allow your computer to access more memory to speed up loading larger files.

Hope this helps,
Jia  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...